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Chapter 1: Introduction 
 
The SNMP-NV6 Manager provides useful information about the power status of the UPS.  It is 
an easy-to-use program that provides you with a complete set of utilities to configure and 
monitor system performance to obtain maximum results.  Its ability to remote monitor and 
control lots of UPSs is only one of the superb features. 
 
SNMP-NV6 Manager Features: 
 

• Remote monitoring and control of UPSs through TCP/IP network 
• Monitoring and control of UPSs through serial communication port 
• Collects information from all of the UPSs into one central location 
• Provides hierarchical architecture to manage all of your UPSs 
• Provides audible alarm, broadcasting, paging, email and SMS notifications 
• Monitors and displays Voltage, Frequency, Current, Loading, Battery Status, etc. 

 
 
Chapter 2: Overview 
 
The SNMP-NV6 Manager is an omnibus UPS management system.  It can manage your UPSs 
through network and also has the ability to manage your UPSs through the serial port.  It 
provides a standard graphic interface so that users can easily manage the UPSs and share a 
common alarm system. 
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Networking: 
There are several ways to manage UPSs through the network by SNMP-NV6 Manager: 

• SentryPlus Software 
• 3Phase SentryPlus Software 
• SNMP-NV6 SNMP card 

 
Serial Port: 
Use an RS232-to-RS485 adapter to cascade UPSs in one serial port or insert a multi-port card 
in the PC to connect UPSs to the serial ports. 
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Chapter 3: Creating UPS Maps 
 

The following example uses SNMP-NV6 Manager to create a simple UPS map.  The map file 
containing the submaps is SouthUPS.UMF.  SouthUPS consists of a home map, three regional 
submaps, and three local submaps for each regional submap. 
 
Table of SouthUPS Submaps 
 
Home Submap Regional Submaps Local Submaps Devices 
World    
 Europe London Lab #11,12 
  Berlin Sales #4 
  Vienna Sales #8 
 Japan Osaka Sales #25,27 
  Tokyo Sales #28,29,30 
 USA New York Marketing #51,52 
  Houston Lab #101,102 
  Los Angeles Sales #83 
 
To create a map file, follow these steps: 

1.  Choose New from the File menu to create a new map.  SNMP-NV6 Manager will 
display an empty map with a name: Main. 

2.  Choose Rename As from the File menu to name the map file Practice. 
 

Adding a Background 
It is not required to use a background for a submap.  They are independent of your UPS 
map data and can be added at any time.  However, if you have access to suitable Bit Map 
images, they will make it easier to position icons. 
1.  Choose Background from the Object menu. 
2.  Press Browse button, choose World.bmp then press OK. 
 

Adding Group Symbols 
To add group symbols to your map, follow these steps: 
1.  Choose Add Group from the Object menu to display the Property dialog box. 
2.  Name the group title. 
3.  Click OK. 
 

Adding SNMP Object Symbols 
To add SNMP Object symbols to your map, follow these steps: 
1.  Choose Add SNMP Object from the Object menu to display the Property dialog box. 
2.  Name the UPS title; fill in the IP address and port number. 
3.  Click on OK and Connect. 
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Chapter 4: File Menu 
 
This section discusses how to handle SNMP-NV6 Manager file and how to load a file at startup. 
 
Connect to Service: 

The SNMP-NV6 Manager-Monitor searches all of the SNMP-NV6 Manager-Service 
programs in the LAN then list them in the Service IP List, if you would like to connect to a 
remote Service that is not in your domain then assign the IP address in the IP Address box. 
 
You can also setup the SNMP-NV6 Manage-Monitor to connect to a specific SNMP-NV6 
Manager-Service automatically, please select the Enable option in the Auto-Connect and 
input the specific IP address. 
 

New: 
Create a new file.  If the previous file has been changed it will pop up a dialog box to ask 
you to save the previous file. 

 
Open: 

Open a previous saved file. 
 
Auto-Load: 

This dialog box is used to setup the Service program to load an assigned UMF file at startup. 
The next time you restart your system the Service program will load the UMF file 
automatically. 

 
Save: 

Save current layout and settings. 
 
Rename As: 

The Rename As menu allows you to save current map file to the other file name. If you do 
not enable the database option to save records in a database then the event log and UPS 
historical parameters in your hard drive will be moved to the new directory automatically. 

 
Generate Report: 

Used for generating the routine reports. You can assign a period of time for SNMP-NV6 
Manager to do the statistics of UPS historical parameters and analyze the UPS event log. 
The report files will be placed in the \Report subdirectory of the SNMP-NV6 Manager 
directory. 

 
Database: 

SNMP-NV6 Manager has the ability to connect to a database through ODBC to save UPS 
event log, user operation log and UPS historical values in the database. If this function is not 
being activated, all of the data will be saved in the installed directory of SNMP-NV6 
Manager-Service. 
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Database Configuration: 
Add a new database named ups in SQL 2005 and assign an account to manage it (admin1). 
SNMP-NV6 Manager will login to the database by using this account. 
 
ODBC connection: 
1.  Create a new account from your Windows operating system with administrative privilege 
(odbc1). 
2.  Login to Windows by this account (odbc1). 
3.  Open the System Administrative Tools from the Control Panel, open the Data Source 
(ODBC) and create a new data source, input the related information and press Next Step. 
4.  Input the account and password that you have assigned (admin1) then press Next Step. 
5.  Set the ups to be the default database then press Next Step and complete the 
configuration. 
 
SNMP-NV6 Manager Installation: 
1.  Now please proceed to install the SNMP-NV6 Manager. 
2.  Open the Service from System Administrative Tools in the Control Panel. Open the 
Property of SNMP-NV6 Manager and switch to the Login page, select Login by this account 
and input the account (odbc1) and password. 
 
SNMP-NV6 Manager Database Configuration: 
Select database from the File menu. The Source Name must be the same as it is in the 
ODBC. The Login Account and Password must be the database administrative account 
(admin1). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Restart System: 
1.  Please restart your operating system, SNMP-NV6 Manager-Service should start up and 
connect to the database automatically. 
2.  To make sure the SNMP-NV6 Manager-Service connects to the database at startup, 
open the SNMP-NV6 Manager-Monitor program and select Database from File menu. Users 
can observe the database connection status here. 
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Initial Database: 
1.  After it connects to the database successfully, press the Establish Tables button to build 
all of the necessary tables in the database.  
2.  The next step is to login SNMP-NV6 Manager as an administrator to add the other users 
account. Select Login from the File menu to open the login dialog box, the default 
administrator’s account is admin and the password is password. There are 3 privileges 
level of users: 

1.  System Administrator: Only responsible for user account management, this level of 
user is not allowed to manage UPS objects. 

2.  UPS Device Manager: Has the ability to manage UPS objects. 
3.  Read-Only User: Only has the read only privilege. 

 
Database Backup Plan: 
There are 3 kinds of records that can be stored in the database: the UPS event log, the 
operation event log and the historical values log.  Most of the device managers would like to 
remove old data from the database and keep the old data in another drive or burn it to a CD 
periodically. To meet this requirement, SNMP-NV6 Manager provides an interface to 
configure its backup plan. 
 
Press the Backup Plan button in the Database dialog box to open the dialog box. You can 
assign the backup directory for each record table and determine how many months data can 
be kept in the database then decide to remove the old records from the database or not. 
 
Remote Monitor ODBC Configuration: 
Install the remote SNMP-NV6 Manager-Monitor program to connect to the same Service 
program for maintenance or monitoring purposes. If the historical values are stored in the 
database then the remote computers needs to configure the ODBC connection as the same 
way as it is in the Service computer. 
 
Note:  The Data Source (ODBC) name must be the same. 

 
Logout: 

Logout of the program. 
 
Change Password: 

Change the password of the current logged in user. 
 

Access Management: 
This function will be enabled if you login as an administrator. Here you can manage the user 
accounts of the SNMP-NV6 Manager system. 
 

Exit: 
Stop the program. 
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Chapter 5: Object Menu 
 
Add Group: 

Add a Group object in the current level.  As you select this option SNMP-NV6 Manager will 
pop up a Property dialog box to let you name the Group title. 

 
Add SNMP Object: 

Add a SNMP object in the current layer.  As you select this menu SNMP-NV6 Manager will 
pop up a Property dialog box to let you name the SNMP title, assign the UPS IP address and 
community string.  The SNMP-NV6 Manager supports only the UPS SNMP.  You can use 
this function to monitor and control the UPS SNMP devices. 

 
Note: The default community string is public. It only has Read-Only permission to UPS. If 
you want to send control commands like schedule shutdown or battery test then you have to 
input the community string with Read/Write permission to the SNMP card. Login to the 
SNMP card via the web browser, open the SNMP Access Control web page and input the IP 
address of the workstation, which runs the SNMP-NV6 Manager. The next step is to decide 
the community string of the SNMP object. The community string of the SNMP-NV6 Manager 
SNMP object and the SNMP card must be the same so that the SNMP packet can pass the 
verification of the SNMP card, which is sent from SNMP-NV6 Manager. Finally, select 
Read/Write option of the Access Level field in SNMP Access Control page to give this object 
Read/Write permission. 

 
Property: 

Displays the selected SNMP Object’s properties and allows you to modify the values. 
 

Background: 
This option allows you to configure the background bitmap.  The SNMP-NV6 Manager only 
supports bitmap file format. 

 
Move: 

To move between objects or move into the selected group or move back to the upper level. 
 
Move Up: Press Up Arrow or Page Up on the keyboard. 
 

 
 
 
 
 
 
 
 
 
 
 

Main 

Group 1-1 UPS 1-2 Group 1-3 

Group 1-1-1 Group 1-1-2 Group 1-3-1 

Current Level 
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Move Into: Press the Down Arrow, or Page Down on the keyboard or double-click the 
left-button on you mouse. 

 
 
 
 
 
 
 
 
 

Move Next: Press the Right Arrow on the keyboard. 
 
 
 
 
 
 
 
 
 

Move Previous: Press the Left Arrow on the keyboard. 
 
 
 
 
 
 
 
 
 
Lock Object: 

Enable this item to prevent from dragging, deleting or cutting any object. 
 
Move: 

Puts the map window back on the top layer.  Takes approximately 1-minute. 
 
Cut: 

Cut the selected object to the clipboard.  You can paste it to a different layer. 

Main 

Group 1-1 UPS 1-2 Group 1-3 

Group 1-1-1 Group 1-1-2 Group 1-3-1 

Current Level 

Main 

Group 1-1 UPS 1-2 Group 1-3 

Group 1-1-1 Group 1-1-2 Group 1-3-1 

Current Level 

Main 

Group 1-1 UPS 1-2 Group 1-3 

Group 1-1-1 Group 1-1-2 Group 1-3-1 

Current Level 
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Paste: 
Paste the object, which was previously cut.  The Cut and Paste commands allow you to 
move the objects. 

 
Delete: 

Delete the selected object. 
 

Delete All: 
Delete all of the objects. 

 
 
Chapter 6: Management Menu 
 
Connection: 

The Time Period to Establish Connection: The SNMP-NV6 Manager tries to establish 
connection to those disconnect networking UPSs in a period of time. 
 
SNMP Polling Interval: Adjusting this value will reduce the SNMP packages in the network. 

 
List/Tab Selection: 

This allows you to change the display columns of the list view and tab number. 
 
Alarm Management: 

This allows you to manage all of the alarm levels and the reactions. There are 3 alarm levels: 
Serious, warning and information. Each level is associated to a group of reactions, such as 
playing audio files, sending e-mail. 
 

Historical Data Management: 
This function is used to manage the event log and historical parameters. To manage 
database, select File->Database->.Backup Plan. 
 

Pause Reaction: 
Selecting this option will pause all of the alarm actions until a new alarm occurs. 
 
Alarm Management provides an interface to configure all of the alarm level and reactions. If 
your UPSs are spread across a large area and have different device managers responding 
to different groups of UPSs. Then you may need to notify different contactors by different 
UPS objects or groups. Using the SNMP-NV6 Manager can easily configure the contactors 
and assign the object and/or group to different contactors. Furthermore, to reduce the 
notification loading in the Service program, the Monitor program can also send notification 
from the remote side. 

 
Contactors: 

Allows you to add, delete or modify the contactor’s information and saves it in the Service 
program. 
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Send Notification From Service: 
Select a group or object from the Rest Object list then press the Add button to add it to the 
Selected Object list. Select a group or object from the Selected Object list then press the 
Remove button to remove from the Selected Object list. Press the Save button to save the 
notification table in the Service program. This table is used for SNMP-NV6 Manager-Service 
to send notifications to the specified contactors. 
 

Send Notification From Monitor: 
Select a group or object from the Rest Object list then press the Add button to add it to the 
Selected Object list. Select a group or object from the Selected Object list then press the 
Remove button to remove from the Selected Object list. Press the Save button to save the 
notification table in the Monitor program. This table is used for SNMP-NV6 Manager-Monitor 
to send notifications to the specified contactors. 
 

All Event Log: 
This allows you to view the past events of all the objects.  To print the event log, click on the 
Print command button.  Pressing the Clear All button will clear all of the alarms. 
 
Maximum alarm entries: It allows you to store up to a maximum of 1,000 entries (1-1,000) by 
keying in the number of entries you wish to store. 
 

Selected Event Log: 
This allows you to observe the event logs of the selected UPS. If the database is enabled 
then you can also query the user operation log, too. Click on the Export button to save the 
query data in Excel format. 
 

Historical Parameters: 
This allows you to observe the historical parameters of the selected UPS. Click on the Export 
button to save the query data in Excel format. 
 

Download UPS Event Log: 
This allows you to download the UPS event logs. 
 

Control: 
In this dialog box, you can send control commands to the selected UPS or the UPSs in the 
current group or all of the UPSs. If you are controlling the SNMP object then the object 
should have a permission of Read/Write. 
 
Login to the SNMP card via web browser, open the SNMP Access Control web page and 
enter the IP address of the workstation, which runs the SNMP-NV6 Manager. The next step 
is to decide the community string of the SNMP object. The community string of the 
SNMP-NV6 Manager SNMP object and the SNMP card must be the same so that the SNMP 
packet can pass the verification of the SNMP card, which is sent from SNMP-NV6 Manager. 
Finally, select the Read/Write option of the Access Level field in SNMP Access Control page 
to give this object Read/Write permission. 
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SNMP Batch Configuration: 
This function is used to configure all of your SNMP cards quickly and efficiently. Before 
proceeding to perform the batch configuration, verify the firmware version of the SNMP card 
is v1.14 or later. 
 
Select an SNMP object from the Source SNMP Device List and press the Download System 
Configuration File button and Download SNMP Configuration File button to get the 
description files. Please read the comments in the description files carefully. If it is not 
necessary to update the item or you don’t understand what it means, then delete the item 
from the list. After completing the modification, select the target SNMP device from the 
SNMP Device List, clicking on the Upload System Configuration File button to update the 
system configuration or press the Upload SNMP Configuration File button to update the 
SNMP configuration to the target SNMP card. 
 

Control Password Setup: 
This function is used to verify the privileges of users to open the Control dialog box. It is only 
available when SNMP-NV6 Manager is not connected to the database. 
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